Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. *Read more...*

Feature #853803 ยป 0020-Document-with-qt5x.patch

Marko Lindqvist, 2020-10-19 02:20 AM

View differences:

INSTALL
This file describes how to compile and install Freeciv. Last time we
made sure this file is up to date was 16-Jul-06.
Last minor update was 16-Apr-20.
Last minor update was 19-Oct-20.
There may be a localized version of this file in the ./doc directory,
named INSTALL.<locale> (e.g., INSTALL.de).
......
- Qt5Core, Qt5Gui, and Qt5Widgets libraries and headers.
At least version 5.11 is required.
If one builds with configure option --with-qt5x,
at least version 5.14 is required.
2. Generating Makefiles
doc/README.packaging
implementation supports it.
* Minimum Qt5 requirement for Qt-client, Qt modpack installer, and
Ruledit is 5.11.
* New configure option --with-qt5x builds versions of Qt programs
that require and take advantage of newer Qt versions. It makes
minimum Qt5 requirement to be 5.14.
----------------------------------------------------------------------
Compatibility of modified versions
    (1-1/1)