Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #308257

closed

Some erros

Added by Anonymous almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Bug
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:

Description

I have no clear idea why this happens, so I don't make steps this time.

But it appears if I try to control the ship from the airlock (just a little error notice, but it doesn't do anything else) and sometimes when I crash into something. Probably it's caused by the new fire system. So far I didn't manage to get a fire, just errors. My safe and all files are completely fresh.

I'll upload a few screenshots.


Files

Screenshot (85).png (399 KB) Screenshot (85).png Anonymous, 2014-06-10 09:56 PM
Screenshot (87).png (825 KB) Screenshot (87).png Anonymous, 2014-06-10 09:56 PM
Screenshot (86).png (827 KB) Screenshot (86).png Anonymous, 2014-06-10 09:57 PM
Screenshot (88).png (834 KB) Screenshot (88).png Anonymous, 2014-06-10 09:57 PM
Screenshot (89).png (832 KB) Screenshot (89).png Anonymous, 2014-06-10 09:57 PM
Actions #1

Updated by Anonymous almost 10 years ago

I've tested the new build you gave me.
So far I had no error. It seems to be fine.
Not sure if the newer build messed up my old one (which is still present for testing) but also with the old one the bug doesn't occur again. It seems like my save is gone, too. Dunno.
However the bug seems to be gone. Maybe it was just a corrupted save?

I'll leave a notice if it appears again.

Actions #2

Updated by Brendan Anthony almost 10 years ago

  • Status changed from New to Resolved
  • Sprint/Milestone set to 1.1.0

I think I've figured out what happened. I suspect you went to the airlock computer as described, BUT before you tried to pilot the ship, you first went to the ship layout editor.

Going from the ship editor back to the airlock menu will clear out the existing interior/fire data. Then if you tried to pilot the ship without exiting the airlock menu, the interior wouldn't have fire data yet and died.

Realized this while at Home Depot earlier today :P Then came home and was able to reproduce the bug finally. Should be fixed in the version currently available!!!

Thanks for reporting this! It was a stupid mistake :)

Actions #3

Updated by David Karl almost 10 years ago

  • Status changed from Resolved to Closed

Closed in version 1.1.0

Actions #4

Updated by David Karl almost 10 years ago

  • % Done changed from 0 to 100
Actions #5

Updated by Anonymous almost 10 years ago

So far I didn't manage to reproduce the bug like you said.
Did you fix that in the version that you've gave me? Not sure.
And are there any special conditions to get a fire?
Kinda weird. Maybe it's because I'm just a few minutes away from the spawn?

Anyway it's fine you fixed it. :)

Actions #6

Updated by Brendan Anthony almost 10 years ago

Did you fix that in the version that you've gave me? Not sure.

Yes! The bug shouldn't happen at all in the version I gave you. I had already fixed it without being totally sure what ultimately caused the bug by then :)

And are there any special conditions to get a fire?

Nope, you just have to get damaged in combat or a collision. Although the official 1.1.0 build has fires much more often than your build does. I also raise the chances of getting a fire every X minutes so if you play for a bit you'll definitely see one :D

Also available in: Atom PDF