Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Task #656700

Update freeciv-web build process to work with git-based freeciv server

Added by Marko Lindqvist over 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Freeciv-web
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:

Description

I don't know if we can do anything before breaking things by migrating freeciv to git, and only then fixing freeciv-web.

Assigning to Sveinung as he's most likely to being both capable of doing the change, and not overly busy with other gna.org migration stuff.


Related issues

Blocked by Freeciv - Task #663033: Migration to gitClosed2017-04-02

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Sveinung Kvilhaugsvik over 5 years ago

  • Status changed from New to Assigned

#2 Updated by Sveinung Kvilhaugsvik over 5 years ago

If SVN goes down before the git conversion is ready we could use a git-svn history + dl_freeciv_from_git_svn.sh.dist. If being able to rebuild on https://play.freeciv.org/ is enough no changes to freeciv-web is needed. Travis (and Vagrant) could be supported by placing a tarball with a git-svn freeciv history somewhere on the internet and modify the build scripts to use it + dl_freeciv_from_git_svn.sh.dist.

#3 Updated by Marko Lindqvist about 5 years ago

#4 Updated by Jacob Nevins about 5 years ago

Once Freeciv is properly in git, freeciv-web's dependence on a specific version seems like a natural application of git submodules.

On the other hand, my friends who've used them (I haven't, really) complain that they are unsatisfactory in various ways. So, prepare to use them and be slightly disappointed, I guess.

#5 Updated by Sveinung Kvilhaugsvik about 5 years ago

On the other hand, my friends who've used them (I haven't, really) complain that they are unsatisfactory in various ways.

We already use a script to download and build freeciv-web. It can do the submodule specific (not general git) things.

#6 Updated by Andreas Røsdal about 5 years ago

Now that svn.gna.org is down, I hope that we can complete the migration of Freeciv to GitHub very soon.

#7 Updated by Marko Lindqvist about 5 years ago

Has this been done already?

#8 Updated by Sveinung Kvilhaugsvik about 5 years ago

I don't think it has been fully done but Andreas has made Freeciv-web work with the new tree. (Correct me if I'm wrong, Andreas.)

I hope to do this next week.

#9 Updated by Jacob Nevins about 5 years ago

https://github.com/freeciv/freeciv-web/tree/develop/freeciv has clearly had some work done to it...

#10 Updated by Andreas Røsdal about 5 years ago

Yes, it is working, but could be done better and more efficient. There are some warnings on git checkout. Any improvements welcome.

#11 Updated by Sveinung Kvilhaugsvik about 5 years ago

Jacob Nevins wrote:

https://github.com/freeciv/freeciv-web/tree/develop/freeciv has clearly had some work done to it...

Was my English bad? Trying again: Andreas has made Freeciv-web work with the new tree. I didn't think the solution was intended to be permanent. (This was based on a quick.) I asked Andreas for a correction in case I was wrong.

Andreas Røsdal wrote:

Yes, it is working, but could be done better and more efficient. There are some warnings on git checkout. Any improvements welcome.

Thank you for the information, Andresa. I'll try to get something done by next week.

#12 Updated by Sveinung Kvilhaugsvik almost 5 years ago

  • Category set to Freeciv-web
  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Sveinung Kvilhaugsvik wrote:

On the other hand, my friends who've used them (I haven't, really) complain that they are unsatisfactory in various ways.

We already use a script to download and build freeciv-web. It can do the submodule specific (not general git) things.

That statement assumed that everyone would rebuild Freeciv before committing. Someone just modifying some JavaScript may not do a full rebuild. Putting submodule specific stuff in the Freeciv build script would therefore not solve the problem of accidental submodule update reverts.

I ended up using git plumbing commands to check out a copy of Freeciv: https://github.com/freeciv/freeciv-web/commit/5343cead69af14e0417abab8c785c5044b3e3a10

I updated references to SVN: https://github.com/freeciv/freeciv-web/commit/5509c98ad8336b01e91447db60d7edaf4b4dc448

I therefore consider this task done. Feel free to reopen if anything is missing.

(Andreas created temporary solutions for checking out Freeciv first from repo.or.cz and then from from github)

Also available in: Atom PDF