Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Feature #683532

citizens_graphic / citizens_graphic_alt don't do anything

Added by Jacob Nevins almost 5 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Low
Category:
Client
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

We've been carrying ruleset support for specifying citizens_graphic / citizens_graphic_alt on a per-city-style basis since 2003 (commit:c70b3c37e1), but it's never been wired up to the tileset, so it doesn't do anything.

It would probably be quite easy to make this work; get_citizen_sprite() looks like it has the relevant information. It would probably need a few redraws to ensure citizen graphics are redrawn when the style changes.


Related issues

Blocks Freeciv - Task #939772: S3_2 datafile format freeze (d3f)New

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist about 4 years ago

  • Sprint/Milestone set to 3.0.0

#2 Updated by Marko Lindqvist about 4 years ago

  • Blocks Task #656466: S3_0 datafile format freeze (d3f) added

#3 Updated by Marko Lindqvist almost 4 years ago

The format is rather limited. Should we extend the format, or should we derive all the tag names from the single entry currently given?
There's just one entry. We should have tileset-defined number of alternative sprites for each of the happiness types (content, happy, unhappy, angry).

#4 Updated by Marko Lindqvist about 3 years ago

  • Blocks Task #673656: S3_1 datafile format freeze (d3f) added

#5 Updated by Marko Lindqvist about 3 years ago

  • Sprint/Milestone changed from 3.0.0 to 3.1.0

#6 Updated by Marko Lindqvist about 3 years ago

  • Blocks deleted (Task #656466: S3_0 datafile format freeze (d3f))

#7 Updated by Marko Lindqvist 5 months ago

Preparatory patch: https://osdn.net/projects/freeciv/ticket/43582

This seems to be getting more complicated than originally assumed. I'm inclined to postpone this again (to 3.2). The above patch has already been targeted to 3.2 on that assumption -> also it needs to be ported if we are to keep 3.1 target for this.
There's no kind of regression in this in 3.1, so that shouldn't block postponing.

#8 Updated by Marko Lindqvist 4 months ago

https://osdn.net/projects/freeciv/ticket/43650 is about dropping the _alt part of this. There's already a number of fallbacks, and adding another one would just cause confusion of what's the order they are applied, as well as making the implementation much more ugly.

#9 Updated by Marko Lindqvist 4 months ago

#10 Updated by Marko Lindqvist 4 months ago

  • Blocks deleted (Task #673656: S3_1 datafile format freeze (d3f))

#11 Updated by Marko Lindqvist 4 months ago

  • Blocks Task #939772: S3_2 datafile format freeze (d3f) added

#12 Updated by Marko Lindqvist 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF