Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #720562

closed

Unreadable and therefore unplayable font size in an MSYS2 GTK3 260b1 client

Added by frank e about 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
gui-gtk-3
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Freeciv Version 2.6.0-beta1-msys2 (Beta-Version), gui-gtk-3.0-Klient.
Built against gtk+ 3.22.16, using 3.22.16
Built against glib 2.52.3, using 2.52.3
Ignore the German gibberish, it's some Windows 64bit client I tested: The font size of the chat window is unreadable (for me, old eyes, old glasses, the works), notably it is not what it should be per client options.

Files

bad font size.png (146 KB) bad font size.png frank e, 2017-12-19 05:21 AM
good fonts.png (92.7 KB) good fonts.png frank e, 2017-12-19 05:21 AM

Related issues

Related to Freeciv - Bug #693382: Gtk3/3.22 theme is not good with recent Gtk3New

Actions
Actions #1

Updated by Jacob Nevins about 6 years ago

  • Sprint/Milestone deleted (2.6.0-beta2)
Actions #2

Updated by Jacob Nevins about 4 years ago

  • Related to Bug #693382: Gtk3/3.22 theme is not good with recent Gtk3 added
Actions #3

Updated by Marko Lindqvist over 1 year ago

  • Sprint/Milestone set to 3.0.3

frank e wrote:

notably it is not what it should be per client options.

So there's an actual bug in there, not just bad defaults (and may mean that user can't get good font even by changing it from the settings)

Actions #4

Updated by Marko Lindqvist over 1 year ago

Marko Lindqvist wrote:

frank e wrote:

notably it is not what it should be per client options.

So there's an actual bug in there, not just bad defaults (and may mean that user can't get good font even by changing it from the settings)

Can't reproduce (on linux, with newish glib/gtk+-3) in any branch, including S2_6. Increasing the "chat area" font size to 15 obviously makes the text bigger.

Actions #5

Updated by Marko Lindqvist over 1 year ago

  • Sprint/Milestone changed from 3.0.3 to 3.0.4
Actions #6

Updated by Marko Lindqvist over 1 year ago

  • Category changed from Client to gui-gtk-3.22
  • Sprint/Milestone changed from 3.0.4 to 3.0.5
Actions #7

Updated by Marko Lindqvist about 1 year ago

  • Sprint/Milestone changed from 3.0.5 to 3.0.6
Actions #8

Updated by Marko Lindqvist about 1 year ago

  • Category changed from gui-gtk-3.22 to gui-gtk-3
  • Priority changed from High to Normal

Actually this was the ancient gtk3-client (we did some builds of it too, in the very early days of msys2 support).

If nobody has seen the problem with gtk3.22-client, I'll close this ticket.

Actions #9

Updated by Marko Lindqvist about 1 year ago

  • Status changed from New to Closed
  • Assignee set to Marko Lindqvist

Marko Lindqvist wrote in #note-8:

If nobody has seen the problem with gtk3.22-client, I'll close this ticket.

One minor release cycle, almost two months, has passed, with no comment -> closing.

Also available in: Atom PDF