Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. *Read more...*

Bug #763890

closed

Hut on NoCities flag terrain wouldn't turns to settlers in civ2civ3

Added by Akechi . over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

It seems #700906.

From http://freeciv.wikia.com/wiki/Forum:Some_tiny_issues (15):

In Freeciv 2.6.0 beta0 c3114c64a6, if you entered hut with NoCities flag terrain (e.g. civ2civ3's Mountains), and hut bonus is city or settler, you gain 25 gold instead of Settlers even if ruleset defines CitiesStartUnit role unit.
(data\default\default.lua _deflua_hut_get_city)
I think this code:
local settlers = find.role_unit_type('Cities', owner)
should be:
local settlers = find.role_unit_type('CitiesStartUnit', owner)


Files

26c2c3_mountain_huts.sav.bz2 (15 KB) 26c2c3_mountain_huts.sav.bz2 S2_6 civ2civ3, test for huts in mountains Jacob Nevins, 2018-07-08 10:39 AM

Related issues

Related to Freeciv - Bug #700906: 2.6: can never get Settler-type units from hutsClosedJacob Nevins

Actions
Blocks Freeciv - Task #656706: Handle http://freeciv.wikia.com/wiki/Forum:Some_tiny_issuesNew

Actions
Actions #1

Updated by Jacob Nevins over 4 years ago

  • Related to Bug #700906: 2.6: can never get Settler-type units from huts added
Actions #2

Updated by Jacob Nevins over 4 years ago

Confirmed with the editor that the predicted behaviour (25 gold instead of Settlers) does occur in practice.
(With the attached savegame, and an edit to _deflua_hut_get_city() to print a special message on this code path.

It seems #700906.

Indeed. More discussion added to that ticket.

Actions #3

Updated by Jacob Nevins over 4 years ago

This is a regression from 2.5, because there "Cities" was a role, and now it's a flag.

Actions #4

Updated by Jacob Nevins over 4 years ago

  • Status changed from New to Rejected

Rejected; the reported symptom was valid, but has been fixed another way under bug #700906.

Actions #5

Updated by Jacob Nevins over 4 years ago

  • Blocks Task #656706: Handle http://freeciv.wikia.com/wiki/Forum:Some_tiny_issues added

Also available in: Atom PDF