Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #853598

Meson: Windows: too many arguments to function ‘mkdir’

Added by Marko Lindqvist over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Bootstrap
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Cross-compiling (meson-winbuild.sh) to Windows with meson:

../../../utility/shared.c: In function ‘make_dir’:
../../../utility/shared.c:1718:5: error: too many arguments to function ‘mkdir’
mkdir(path, 0755);


Related issues

Is duplicate of Freeciv - Feature #852980: Meson: Define FREECIV_MSWINDOWS when building for windowsClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist over 2 years ago

From the #ifdefs around there I think this will get fixed by Feature #852980

#2 Updated by Marko Lindqvist about 1 year ago

  • Is duplicate of Feature #852980: Meson: Define FREECIV_MSWINDOWS when building for windows added

#3 Updated by Marko Lindqvist about 1 year ago

  • Status changed from New to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF