Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #854983

civ2civ3 ruleset, version 3.0.92-dev - can't Disembark from Caravel with goto

Added by Chippo Elder over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Using version 3.0.92-dev, gui-gtk-3.22 client, the civ2civ3 ruleset and the attached savegame, the caravel at [l tgt="unit" id=1364 name="Caravel" /] cannot unload any of the 3 units it has on board.

As far as I can tell, all three units aboard should legally be able to unload onto the tile due south of the caravel. I also tried the -qt and -sdl2 clients and they have the same incorrect behaviour.

freeciv-T0119-Y00360-auto.sav.xz (75.5 KB) freeciv-T0119-Y00360-auto.sav.xz Chippo Elder, 2020-01-07 10:08 AM

Related issues

Related to Freeciv - Feature #850768: path finding: explicit alight/disembark supportNew

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Jacob Nevins over 2 years ago

  • Subject changed from civ2civ3 ruleset, version 3.0.92-dev - cannot unload units from caravel to civ2civ3 ruleset, version 3.0.92-dev - can't Disembark from Caravel with goto
  • Sprint/Milestone set to 3.1.0

(Slightly to my surprise, this savegame loads into S3_0, and there doesn't seem to be a problem there.)

Reproduced with master. I think this is something to do with generalised actions.

With Gtk3.22, I select the Caravel and do Shift+T (ready its cargo), then for each cargo unit I either:
  • Press (G). The client is happy to plot a cyan route to wherever; but when I left-click to make the unit move, nothing happens. (Not even a "couldn't find a route to the destination" type of message.)
  • Use the numpad. This pops up an action menu, with choices Disembark / Keep moving / Show Location / Wait / Cancel. Choosing "Disembark" allows the unit to get off.

It looks like the UI needs more work to avoid regressions... given those choices, probably Disembark should just happen automatically.

#2 Updated by Chippo Elder over 2 years ago

I had originally decided to playtest civ2civ3 ruleset with master (-dev). This exact bug forced me to switch to S3_0, 'cos I couldn't get off the transports.

Jacob Nevins wrote:

Choosing "Disembark" allows the unit to get off.

Now, that you've found a way, I could go back to playtesting master. But I've had plenty of fun playtesting S3_0. From the projects point of view, is one of the branches more in need of testing than the others?

#3 Updated by Sveinung Kvilhaugsvik over 2 years ago

  • Related to Feature #850768: path finding: explicit alight/disembark support added

#4 Updated by Marko Lindqvist over 1 year ago

  • Assignee set to Sveinung Kvilhaugsvik

Jacob Nevins wrote:

It looks like the UI needs more work to avoid regressions... given those choices, probably Disembark should just happen automatically.

Is this still an issue?

#5 Updated by Sveinung Kvilhaugsvik over 1 year ago

Marko Lindqvist wrote:

Jacob Nevins wrote:

It looks like the UI needs more work to avoid regressions... given those choices, probably Disembark should just happen automatically.

Is this still an issue?

Yes. But I have moved regular moves to enabler control so the path finding work is approaching.

#6 Updated by Sveinung Kvilhaugsvik about 1 year ago

  • Category set to General
  • Status changed from New to Closed

This particular issue has been fixed by mapping unit move orders to actions during order execution in https://osdn.net/projects/freeciv/ticket/42581

A goto that picks action - Feature #850768 - is still not done. Closing as the UI case listed here now is fixed.

Also available in: Atom PDF