Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #858746

Setting a rally point out of the map crashes the Qt client

Added by Louis Moureaux over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
gui-qt
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Steps to reproduce:

  • In the Qt client, start setting a rally point
  • Navigate to see the black area beyond the map boundaries
  • Click out of the map

The client will crash because it tries to find the tile under the mouse, and there is none.

The crash has been confirmed in 2.6 and 3.0, in master by reading the code I looks like it will assert() somewhere in the functions setting rally orders (not tested).

Related to #830553 (and fix there handles 2.6 and 3.0)


Related issues

Related to Freeciv - Bug #830553: Qt client may crash when setting a rally point and the city is lostClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Jacob Nevins over 2 years ago

  • Related to Bug #830553: Qt client may crash when setting a rally point and the city is lost added

#2 Updated by Jacob Nevins over 2 years ago

  • Sprint/Milestone set to 3.1.0

#3 Updated by Jacob Nevins over 2 years ago

  • Category set to gui-qt

#5 Updated by Marko Lindqvist about 2 years ago

  • Assignee set to Marko Lindqvist

#6 Updated by Marko Lindqvist about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF