Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Task #858829

Refresh "dev" modpacks for current unfrozen master (3.1) data formats

Added by Chippo Elder over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Rulesets
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Start freeciv-mp-gtk3 and try install Ancients.

You see the attached screenshot.

In the console you see:

chippo@chippo-Aspire-V3-731:~$ freeciv-mp-gtk3-dev-noasn-checks 
Encodings: Data=UTF-8, Local=UTF-8, Internal=UTF-8
3: Installing modpack amplio.mpdl from http://files.freeciv.org/modinst/dev/amplio.mpdl
3: Installing modpack experimental.mpdl from http://files.freeciv.org/modinst/dev/experimental.mpdl
3: Installing modpack ancients-eafd85906d.mpdl from http://files.freeciv.org/modinst/dev/ancients-eafd85906d.mpdl
1: Incompatible control file:
1:   control file options: +Freeciv-modpack-Devel-2016.Feb.05
1:   supported options:    +Freeciv-mpdl-Devel-3.1-2019.Jul.15

ancients-incompat.png (103 KB) ancients-incompat.png Chippo Elder, 2020-02-06 07:59 AM
dev-mp-installed.png (102 KB) dev-mp-installed.png Chippo Elder, 2020-02-06 08:12 AM
250
250

Related issues

Blocks Freeciv - Task #656468: S3_1 branchingClosed2021-02-06

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Chippo Elder over 2 years ago

And,

3: Installing modpack variant2-be09da651a.mpdl from http://files.freeciv.org/modinst/dev/variant2-be09da651a.mpdl
1: Incompatible control file:
1:   control file options: +Freeciv-modpack-Devel-2016.Feb.05
1:   supported options:    +Freeciv-mpdl-Devel-3.1-2019.Jul.15

#2 Updated by Chippo Elder over 2 years ago

250

And,

3: Installing modpack delta2-4e481111ef.mpdl from http://files.freeciv.org/modinst/dev/delta2-4e481111ef.mpdl
1: Incompatible control file:
1:   control file options: +Freeciv-modpack-Devel-2016.Feb.05
1:   supported options:    +Freeciv-mpdl-Devel-3.1-2019.Jul.15

And,

3: Installing modpack deltasquare-4e481111ef.mpdl from http://files.freeciv.org/modinst/dev/deltasquare-4e481111ef.mpdl
1: Incompatible control file:
1:   control file options: +Freeciv-modpack-Devel-2016.Feb.05
1:   supported options:    +Freeciv-mpdl-Devel-3.1-2019.Jul.15

And,

3: Installing modpack freeland-4e481111ef.mpdl from http://files.freeciv.org/modinst/dev/freeland-4e481111ef.mpdl
1: Incompatible control file:
1:   control file options: +Freeciv-modpack-Devel-2016.Feb.05
1:   supported options:    +Freeciv-mpdl-Devel-3.1-2019.Jul.15

And,

3: Installing modpack freeland-big-4e481111ef.mpdl from http://files.freeciv.org/modinst/dev/freeland-big-4e481111ef.mpdl
1: Incompatible control file:
1:   control file options: +Freeciv-modpack-Devel-2016.Feb.05
1:   supported options:    +Freeciv-mpdl-Devel-3.1-2019.Jul.15

And,

3: Installing modpack chess-4e481111ef.mpdl from http://files.freeciv.org/modinst/dev/chess-4e481111ef.mpdl
1: Incompatible control file:
1:   control file options: +Freeciv-modpack-Devel-2016.Feb.05
1:   supported options:    +Freeciv-mpdl-Devel-3.1-2019.Jul.15

After you've tried to install everything, it will look like the attached screenshot.

#3 Updated by Marko Lindqvist over 2 years ago

This is expected in a branch where datafile formats are not yet frozen. Custom modpacks are updated only occasionally, not constantly as the engine changes.

#4 Updated by Jacob Nevins over 2 years ago

  • Tracker changed from Bug to Task
  • Subject changed from Ancients modpack is incompatible (master) to Refresh "dev" modpacks for current unfrozen master (3.1) data formats

Moving ticket to more appropriate category, but no promise that it gets done on any particular timescale (it may end up rejected).

#5 Updated by Marko Lindqvist over 2 years ago

#6 Updated by Marko Lindqvist over 2 years ago

Jacob Nevins wrote:

any particular timescale

Probably shortly before S3_1 branching, to minimize need to make same updates against two branches (S3_1 & master) separately.

#7 Updated by Marko Lindqvist over 1 year ago

  • Category set to Rulesets
  • Status changed from New to Closed
  • Assignee set to Marko Lindqvist
  • Sprint/Milestone set to 3.1.0

Marko Lindqvist wrote:

Jacob Nevins wrote:

any particular timescale

Probably shortly before S3_1 branching, to minimize need to make same updates against two branches (S3_1 & master) separately.

Most modpacks have been updated at least once since this ticket was created, and are currently relatively up-to-date. Given that we have no better defined target for this ticket, closing.

Also available in: Atom PDF