Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Feature #879677

Tile targeted actions: evaluate local dilprel reqs against targe tile city owner when borders are disabled

Added by Sveinung Kvilhaugsvik about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
General
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

With borders disabled a tile has no owner and is unclaimed even if it has a city. This means that tile targeted action enablers can't specify local diplomatic requirements against any city at the target tile in enabler.

My current implementation makes "Center" a sub set of "Claimed" by setting the tile owner to the owner of any city on that tile even if borders are disabled. Not done yet. I haven't found out why my autogames are different.

tmp.patch (2.23 KB) tmp.patch Sveinung Kvilhaugsvik, 2020-07-01 03:45 AM

History

#1 Updated by Sveinung Kvilhaugsvik about 2 years ago

  • Status changed from New to In Progress

#2 Updated by Sveinung Kvilhaugsvik about 2 years ago

Autogame difference could be AI checking claimed. It could also be that I have missed some rule or intruded a bug.

#3 Updated by Sveinung Kvilhaugsvik about 2 years ago

  • Category set to General
  • Status changed from In Progress to Resolved
  • Sprint/Milestone set to 3.1.0

The auto game difference was caused by path finding pulling out early when it discovered that the tile was claimed by someone the player had peace with. This patch made the path finding understand that moving through a tile with a city owned by someone the player has peace with is just as difficult as moving through a tile owned by someone the player has peace with.

#4 Updated by Sveinung Kvilhaugsvik about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF