Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Feature #880897

CI: test Windows build

Added by Sveinung Kvilhaugsvik about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Bootstrap
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Travis has experimental Windows support. Github actions has Windows support.

History

#1 Updated by Marko Lindqvist about 2 years ago

When this was last attempted with Travis CI, the problem was that build took longer than Travis timeout.

#2 Updated by Sveinung Kvilhaugsvik about 2 years ago

Marko Lindqvist wrote:

When this was last attempted with Travis CI, the problem was that build took longer than Travis timeout.

I can confirm that this is slow.

Half tested patch attached. It fails properly. In an hour I'll know if it succeeds properly too.

#3 Updated by Sveinung Kvilhaugsvik about 2 years ago

Sveinung Kvilhaugsvik wrote:

In an hour I'll know if it succeeds properly too.

It works: https://github.com/kvilhaugsvik/freeciv/runs/878048193?check_suite_focus=true

#4 Updated by Sveinung Kvilhaugsvik about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF