Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Feature #892507

Avoid using deprecated QLabel::pixmap()

Added by Marko Lindqvist almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
gui-qt
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Qt-5.15 deprecates QLabel::pixmap() overload that returns pixmap pointer. Make our code to use the one that returns pixmap value instead. That is introduced in Qt-5.15 only, so #ifdef FC_QT6_MODE conditional compiling is needed.


Related issues

Blocks Freeciv - Feature #893343: QT_DISABLE_DEPRECATED_BEFORE to match Qt-5.15Closed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Blocked by Freeciv - Feature #892509: Make Qt-5.15 minimum requirement for --with-qt5x buildsClosed

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Marko Lindqvist almost 2 years ago

Marko Lindqvist wrote:

That is introduced in Qt-5.15 only

This also means that the patch cannot be pushed before Qt-5.15 has been made the minimum requirement.

#3 Updated by Marko Lindqvist almost 2 years ago

  • Related to Feature #892509: Make Qt-5.15 minimum requirement for --with-qt5x builds added

#4 Updated by Marko Lindqvist almost 2 years ago

  • Blocks Feature #893343: QT_DISABLE_DEPRECATED_BEFORE to match Qt-5.15 added

#5 Updated by Marko Lindqvist almost 2 years ago

  • Related to deleted (Feature #892509: Make Qt-5.15 minimum requirement for --with-qt5x builds)

#6 Updated by Marko Lindqvist almost 2 years ago

  • Blocked by Feature #892509: Make Qt-5.15 minimum requirement for --with-qt5x builds added

#8 Updated by Marko Lindqvist almost 2 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Marko Lindqvist

Also available in: Atom PDF