Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. *Read more...*

Bug #932788

closed

Исправлена внесенная в 6.01 ошибка обращения к структуре таблиц БД в некоторых конфигурациях

Added by Сергей Старых about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Общее
Sprint/Milestone:
Start date:
2021-07-18
Due date:
% Done:

0%

Estimated time:

Description

http://devtool1c.ucoz.ru/forum/2-1948-1
Вопроизвести не смог

Значение не является значением объектного типа (Метаданные)
{ИнструментыРазработчикаTormozit ОбщийМодуль.ирОбщий.Модуль(12439)}:               Для Каждого ПолеТаблицы Из ТаблицаПолей Цикл                    ПолноеИмяРеквизита = ПолеТаблицы.Метаданные;                    ИмяПоля = ПолеТаблицы.ИмяПоля;                    Если Не ЗначениеЗаполнено(ПолноеИмяРеквизита) Тогда                       Попытка                          МетаРеквизит = ОбъектМД.СтандартныеРеквизиты[ИмяПоля];                       Исключение                          Продолжить;                       КонецПопытки;                       СтрокаПоля = Результат.Найти(ИмяПоля, "Имя");                    ИначеЕсли Ложь                       Или ИмяПоля <> "НомерСтроки"                       Или Найти(ПолноеИмяРеквизита, ".ТабличнаяЧасть.") = 0                    Тогда                       СтрокаПоля = Результат.Найти(ИмяПоля, "Имя");                       Если СтрокаПоля = Неопределено Тогда                          Продолжить;                       КонецЕсли;                       Если Найти(ПолноеИмяРеквизита, ПрефиксРеквизита) = 1 Тогда                            МетаРеквизит = ОбъектМД.Реквизиты[ПоследнийФрагментЛкс(ПолноеИмяРеквизита)];                       Иначе                            МетаРеквизит = ирКэш.ОбъектМДПоПолномуИмениЛкс(ПолноеИмяРеквизита);                       КонецЕсли;                    Иначе                       Продолжить;                    КонецЕсли;                    СтрокаПоля.Метаданные = МетаРеквизит;                    Заголовок = МетаРеквизит.Представление();                    Если ЗначениеЗаполнено(Заголовок) Тогда                       СтрокаПоля.Заголовок = Заголовок;                    КонецЕсли;                    Попытка                       СтрокаПоля.РежимПароля = МетаРеквизит.РежимПароля;                    Исключение                    КонецПопытки;                 КонецЦикла;  
{ИнструментыРазработчикаTormozit ОбщийМодуль.ирКэш.Модуль(68)}:   Результат = ирОбщий.ПоляТаблицыБДЛкс(ПолноеИмяТаблицыБД, _ВызыватьИсключениеПриОтсутствииПрав, ИндексПараметраПериодичность, ВыражениеПараметраПериодичность);
{ИнструментыРазработчикаTormozit Обработка.ирИсторияДанных.МодульОбъекта(110)}:         ПоляТаблицыБД = ирКэш.ПоляТаблицыБДЛкс(ИмяТаблицыБД);
{ИнструментыРазработчикаTormozit Обработка.ирИсторияДанных.МодульОбъекта(45)}:   ТаблицаПолей = ИспользованиеПолей(ОбъектМД, ИспользованиеПолейНастроекИстории);
{ИнструментыРазработчикаTormozit Обработка.ирИсторияДанных.МодульОбъекта(240)}:            ЗаполнитьНастройкиИсторииВСтрокеТипа(НастройкиИстории, ОбъектМД, СтрокаТипаДанных, ВычислятьПоля);
{(1)}:Обработка.РассчитатьИтогиИсторииПоТипам(ПараметрыЗадания)
{ИнструментыРазработчикаTormozit ОбщийМодуль.ирОбщий.Модуль(30748)}:      Результат = Вычислить("Обработка." + ИмяМетодаОбработки + "(ПараметрыЗадания)");
{ИнструментыРазработчикаTormozit Обработка.ирИсторияДанных.Форма.Форма.Форма(37)}:   ирОбщий.ВыполнитьЗаданиеФормыЛкс("РассчитатьИтогиИсторииПоТипам", ПараметрыЗадания, ЭтаФорма, "ИтогиИсторииДанных",, ЭлементыФормы.КПТипы.Кнопки.Обновить,
{ИнструментыРазработчикаTormozit Обработка.ирИсторияДанных.Форма.Форма.Форма(25)}:   КПТипыОбновить();
{ИнструментыРазработчикаTormozit ОбщийМодуль.ирОбщий.Модуль(39510)}:      Форма.Открыть();
{ИнструментыРазработчикаTormozit Обработка.ирИсторияДанных.Команда.Команда1.МодульКоманды(4)}:   ирОбщий.ОткрытьФормуЛкс("Обработка.ирИсторияДанных.Форма");

Actions #1

Updated by Сергей Старых about 1 year ago

  • Sprint/Milestone changed from Разработка to 6.07.2
Actions #2

Updated by Сергей Старых about 1 year ago

  • Subject changed from Исправлена внесенная в 6.01 ошибка обновления истории данных в некоторых конфигурациях to Исправлена внесенная в 6.01 ошибка обращения к структуре таблиц БД в некоторых конфигурациях
  • Category changed from История данных to Общее

Also available in: Atom PDF