Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. *Read more...*

Bug #949287

open

8.3.21-+ Команда "Выделить фрагмент" редактора модуля создает бесполезный параметр

Added by Сергей Старых 5 months ago. Updated about 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

https://partners.v8.1c.ru/forum/t/2079732/m/2079732
https://bugboard.v8.1c.ru/error/000130449
Конфигурация ПО

8.3.21-+

Проблема

Команда "Выделить фрагмент" редактора модуля создает бесполезный параметр

Воспроизведение

В конфигураторе любой базы создать новый общий модуль и вставить в него текст
Процедура Ф()
Запрос = Новый Запрос;
Запрос1 = Новый Запрос;
КонецПроцедуры

Выделить вторую строку тела функции и выполнить команду контекстного меню "Выделить фрагмент".

Получаем функцию с бесполезным параметром "Запрос"
Процедура Ф()
Запрос = Новый Запрос;
ФФрагмент(Запрос);
КонецПроцедуры

Процедура ФФрагмент(Знач Запрос)
Перем Запрос1;
Запрос1 = Новый Запрос;
КонецПроцедуры

А ожидалось функция без параметров.


Files

clipboard-202209012039-t0zdx.png (29.8 KB) clipboard-202209012039-t0zdx.png Сергей Старых, 2022-09-01 07:39 PM
clipboard-202209012039-ed0vn.png (8.56 KB) clipboard-202209012039-ed0vn.png Сергей Старых, 2022-09-01 07:39 PM
Actions #1

Updated by Сергей Старых 5 months ago

  • Subject changed from 8.3.21 Команда "Выделить фрагмент" редактора модуля создает бесполезный параметр to 8.3.21-+ Команда "Выделить фрагмент" редактора модуля создает бесполезный параметр
  • Description updated (diff)
Actions #2

Updated by Сергей Старых about 2 months ago

  • Description updated (diff)

Also available in: Atom PDF