Project

Profile

Help

HostedRedmine.com has moved to the Planio platform. All logins and passwords remained the same. All users will be able to login and use Redmine just as before. Read more...

Bug #974488

Updated by Сергей Старых 5 months ago

https://partners.v8.1c.ru/forum/t/2159739/m/2159739 
 Конфигурация ПО 

 8.3.22-24 

 Проблема 

 Открытие элемента коллекции в отладчике показывает НЕ текущий элемент 

 Воспроизведение 

 Открыть приложенную внешнюю обработку в конфигураторе любой базы с TCP отладкой и установить точку останова на последней строке в коде 
 &НаКлиенте 
 Процедура Команда1(Команда) 
     Функ(); 
 КонецПроцедуры 

 &НаСервере            
 Функция Функ() 
     ТЗ = новый ТаблицаЗначений; 
     ТЗ.Колонки.Добавить("ф"); 
     Для Счетчик = 1 По 1000 Цикл 
         Тз.Добавить().Ф = Счетчик; 
     КонецЦикла; 
 КонецФункции 

 Запустить отладку управляемого клиентского приложения и открыть в нем эту обработку. Нажать в ней кнопку "Команда1". Произойдет остановка в отладчике. Вычислить выражение "ТЗ". Затем открыть коллекцию (ТаблицаЗначений) из результат вычисления. В окне коллекции нажать много раз клавишу "Вниз" или "PgDown" чтобы текущим элементом стал индекс >100. Нажать клавишу F2 и убедиться, что в новом отдельном окне "Выражение" открылся не тот элемент, который является текущим в окне коллекции. 

 Воспроизводится также при перемещении полосы прокрутки указателем мыши. Всеми способами воспроизводится иногда не сразу и может потребоваться пройти подальше от начала коллекции. Есть демонстрация на приложенном видео. 

 !clipboard-202311180934-mmng4.png! 

Back